Site Will Be Down For About A Half An Hour Maybe.

Feb 28 2006, 11:27 PM

I really have to upgrade the hosting software to:

- Apache version 2.0

It's a better version overrall, and the main reason I wish to upgrade to it is that I wish to install mod_security. This is a mod that will stop things like SQL injections on your website and on here. I realize IPB isnt totally safe anymore but this security update will patch MANY if not all of the discovered injections.

It stops the recent QuickArcade 2.x injections completely, and several IPB 2.0 injections so it makes this board safe once again. Its like an auto patch for every single script run on my host, so even if the author makes a mistake you have less of a chance of getting burned.

Pretty cool, and, also if anyone tries to exploit the services each and every attempt gets logged, and I think theres a way to have auto-ban if they try it too many times. So yeah, everyones safety will be greatly affected if I install this and it goes allright.

I already set it up on my laptop to test. Works just fine.

This is a little difficult, but I'll make it work as fast as possible. I already know exactly what Im going to do.

Next, I'll have to:

- Get latest Windows security updates

Not too hard but I do have to download em.

The Upgrade will start at like 12:00am EST so little will notice probably. But I am posting this message so people know in advance what happens.

thanks for your time,
-jcink

Comments

  1. Dylan Says:

    Use Firefox or k-meleon both work. IE is buggy with the admin cp on jcinks host sadly >.<

  2. Ryko Says:

    It worked after about 3 reloadings..

  3. Jcink Says:

    try to reupload the admin.php file, it probably got corrupted then.

  4. Ryko Says:

    I did and it still won't work. The Admin CP login screen won't show up..

  5. Jcink Says:

    Use firefox to access the admincp

  6. Ryko Says:

    I installed IPB 1.3 and the admin CP is blank...

  7. Jcink Says:

    Apache 2.0 is the software that lets you view pages on my host. s' all.

  8. Sean Says:

    That makes no sense... please dont go off topic.

  9. JonnyBocker Says:

    That explains how you code lol let me stop Ill look into it later..

  10. Sean Says:

    Dont worry about it. Its just the software that lets you access jcinks computer and get the webpages.

  11. JonnyBocker Says:

    One question.. i never used - Apache before what does it do? Sorry i aint into much features in hostings.

  12. Ryko Says:

    there we go. I got it... I used quick connect on LeechFTP and it worked like ftp://Name:Pass@freejcinkhosting.afraid.org/

  13. Jcink Says:

    Are you sure you're getting the name right and stuff? name: ryko (lowercase) pass: w/e your pass is. Login and go to ftp manager to make sure its working there.

  14. Ryko Says:

    I can't login into FTP..

  15. Jcink Says:

    Ok that's great, thanks. I should be updating security again soon, with another apache mod. Until then though,

  16. Dylan Says:

    Seems fine to me, Jcink well done ^_^

  17. sebthib55 Says:

    Haha you are right. You did it so fast that not many noticed (I was one)

  18. Jcink Says:

    Reopened, um, if you have any problems with the upgrade please post here. Thanks.

  19. Sean Says:

    I can see where this topic is going. <_<

  20. nerd Says:

    Yep!

  21. Sean Says:

    QUOTE(jonathan)Cool.One-word posts are great. ;D ya just gotta love em

  22. JonnyBocker Says:

    QUOTE(Jcink @ Feb 28 2006, 11:27 PM)I really have to upgrade the hosting software to: - Apache version 2.0It's a better version overrall, and the main reason I wish to upgrade to it is that I wish to install mod_security. This is a mod that will stop things like SQL injections on your website and on here. I realize IPB isnt totally safe anymore but this security update will patch MANY if not all of the discovered injections. It stops the recent QuickArcade 2.x injections completely, and several IPB 2.0 injections so it makes this board safe once again. Its like an auto patch for every single script run on my host, so even if the author makes a mistake you have less of a chance of getting burned. Pretty cool, and, also if anyone tries to exploit the services each and every attempt gets logged, and I think theres a way to have auto-ban if they try it too many times. So yeah, everyones safety will be greatly affected if I install this and it goes allright.I already set it up on my laptop to test. Works just fine. This is a little difficult, but I'll make it work as fast as possible. I already know exactly what Im going to do.Next, I'll have to:- Get latest Windows security updatesNot too hard but I do have to download em.The Upgrade will start at like 12:00am EST so little will notice probably. But I am posting this message so people know in advance what happens.thanks for your time,-jcink[right][snapback]14832[/snapback][/right]Cool.

  23. Jcink Says:

    Upgrade is done!Right on target.

  24. Jcink Says:

    I really have to upgrade the hosting software to: - Apache version 2.0It's a better version overrall, and the main reason I wish to upgrade to it is that I wish to install mod_security. This is a mod that will stop things like SQL injections on your website and on here. I realize IPB isnt totally safe anymore but this security update will patch MANY if not all of the discovered injections. It stops the recent QuickArcade 2.x injections completely, and several IPB 2.0 injections so it makes this board safe once again. Its like an auto patch for every single script run on my host, so even if the author makes a mistake you have less of a chance of getting burned. Pretty cool, and, also if anyone tries to exploit the services each and every attempt gets logged, and I think theres a way to have auto-ban if they try it too many times. So yeah, everyones safety will be greatly affected if I install this and it goes allright.I already set it up on my laptop to test. Works just fine. This is a little difficult, but I'll make it work as fast as possible. I already know exactly what Im going to do.Next, I'll have to:- Get latest Windows security updatesNot too hard but I do have to download em.The Upgrade will start at like 12:00am EST so little will notice probably. But I am posting this message so people know in advance what happens.thanks for your time,-jcink